Troubleshoot 500 Internal Server Error

Problem

Certain or all pages return the web server 500 - Internal Server Error page. This is usually a white page. It is different to the 500 - Whoops! Something went wrong page which is coloured blue and returned by SupportPal.

Cause

There is a problem with your web server configuration or a fatal PHP error has been thrown which could not be handled gracefully by SupportPal.

Resolution

There are many reasons why a 500 - Internal Server Error page can be thrown. Usually an error message will be written to your web server error log in this situation.

Below is a list of troubleshooting steps:

  • Try renaming your .htaccess to htaccess (remove the dot), then browse to the root of your installation directory. For example: https://www.supportpal.com/support/
  • Reset file permissions on your SupportPal directory.
    cd /supportpal/installation/directory
    find . -type d -exec chmod 0755 {} \;
    find . -type f -exec chmod 0644 {} \;
    Ensure the cron and any other processes are all running as the same user.
  • Sometimes the Ioncube Loader can be unreliable and segmentation fault, resulting in an Internal Server Error. Please ensure you're always using the latest version if you notice any issues.